inicio · @abelcastosa · boletín

Si has instalado Gutenberg en tu WordPress es posible que haya empezado a aparecer un mensaje de error como el siguiente en tu panel de administración (/wp-admin) mencionando la función disable_emojicons_tinymce.

Por muchos Warning que aparezcan, la verdad que el problema es sencillo y tiene una solución bastante rápida.

Todo viene provocado porque tienes deshabilitados los emojis (las caritas) que WordPress integra por defecto en su editor clásico. Seguramente tengas una línea como esta en el fichero functions.php del tema que estás usando ahora mismo.

Lo único que tienes que hacer es eliminar, o comentar esa línea, y todo volverá a la normalidad.

Ojo, existe la posibilidad de que no encuentres la línea mencionada en tu fichero functions.php. En este caso habría más opciones, te voy a comentar las más rápidas y normales:

  • Si usas uno de esos temas mágicos que lo hacen todo, es posible que en el functions.php encuentres algunas líneas similares a require_once('ruta/del/fichero.php'). Te toca buscar todos esos ficheros en busca de la línea que menciono anteriormente.
  • Si usas algún plugin relacionado con WPO… es posible que dicho plugin sea el encargado de realizar esa llamada. En este caso puedes editar el plugin (ten en cuenta que si lo actualizas igual vuelve el error) o puedes desactivar el plugin (aunque sea para comprobar que es el causante del error).

Espero que con estos consejos hayas conseguido solucionar el error.

Ivan
13 Ago 2018 - 14:07

Gracias! Lo conseguí gracias a functions.php :)

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.